Frontends

Escargot revolves around frontends and are what power the server. Frontends are simply features or full-fledged protocols that utilize the server's backend to allow them to take advantage of the interlinked presence and messaging features we offer.

Here, we have a list of currently supported frontends and frontends that are planned for implementation, plus a compatibility list of supported clients for each frontend.

If you want to improve or write a new frontend for Escargot, visit the server's GitLab and read our contributing guide to learn how to contribute to the project.

Frontend List

MSN Messenger (MSNP)

Status: Almost complete
Compatibility:

MSN 1
Supported1 6
MSN 2
Supported1
MSN 3
Supported1
MSN 4
Supported1
MSN 5
Supported2
MSN 6
Supported2
MSN 7
Supported2 3
WLM 8
Supported2 4 5
WLM '09
Supported2 5
WLM '11
Not yet
WLM '12
Not yet

Notes

1. Requires "Old MSN support" option.
Beware: MSN 1/2/3/4 do not have secure login at the moment. It's recommended that you only use "Old MSN support" with an account that has a throwaway password.

2. MSN 5/6/7/8 and WLM '09 work on Windows XP and Vista, but have issues logging in due to known incompatibilities with the HTTPS protocols between the server and the affected OSes and us being unable to tweak our setup to effectively support those systems. Refer to this guide for a fix.

3. MSN 7 supports receiving offline messages (OIMs), but can't send them to others.

4. Only 8.1.0178 and 8.5 are known to work; others might not.

5. While WLM 8 and '09 work on Windows XP, it is ill-advised to use them on that platform in a vanilla setting as they relies on HTTPS for several core functions outside of login (a few major ones being group/contact management, roaming profiles, and group chats in WLM '09's case) and without applying a reliable fix to your system, changes you make while logged in might not sync over.

6. MSN 1 only supports login on @hotmail.com accounts by design.


Yahoo! Pager/Messenger (YPNS/YMSG)

Status: Incomplete
Compatibility:

Pager
Not yet
Y!M 2
Not yet
Y!M 3
Not yet
Y!M 4
Not yet
Y!M 5
W.I.P.1 2
Y!M 6
Not yet
Y!M 7
Not yet
Y!M 8
Not yet
Y!M 9
Not yet
Y!M 10
Not yet
Y!M 11
Not yet

Notes

1. Requires "Yahoo! Messenger support" option.
Beware: Yahoo! Messenger 5 does not have secure login and it's recommended that you only use "Yahoo! Messenger support" with an account that has a throwaway password.

2. 5.0.0.1066, 5.5.0.1237, 5.5.0.1244, and 5.5.0.1246 have been tested to work. 5.6 support hasn't been implemented.



AIM (OSCAR)

Coming soon...


More frontends to come soon...